【810】Linkstation LS-WX2.0TL/R1の復旧作業

| コメント(2)

お客さんからLinkstation(LS-WX2.0TL/R1)が全く起動しなくなったので何とかならないかとの相談がありました。症状を聞くと、どうも筆者のLinkstationで以前発生したファームウェア障害と同じ状況みたい。つまり同様の作業をすれば復旧できるかも、ということで早速試してみました。

データは全部消えても構わないとのことだったので、とりあえず内蔵されている2本のHDDを初期化するところから始めます。最近のLinkstationはGPTというフォーマット形式を使っているのですが、WindowsのGUI(コンピュータの管理→記憶域→ディスクの管理)からは初期化できません。このためコマンドラインから「diskpart」というコマンドを使用して領域解放をする必要があります。もちろんKNOPPIXなどのLinuxを使えば、領域解放はもちろん、ファイルの救出も出来ますので、用途に応じてご利用ください。

フォーマットした2本のHDDのうち、1本目だけをセットして電源ON。お約束の赤ランプ6回点滅(=ファームウェアのエラー)となりますので、ここから作業開始です。大まかな作業の流れはこちらのサイトをご覧ください。ただし筆者の環境においては相違点がいくつかありましたので、前述のサイトの内容にプラスして、以下に示すポイントを確認しながら進めてください。ZIPの解凍に使うパスワードが一致しない場合は、こちらにもあるものもお試しください

ポイント 1: ファームウェアは現時点での最新版である1.65を使用

Buffaloのサイトからダウンロードできます。この中のinitrd.imgとuImage.imgを解凍する必要があります。このうち、uImage.imgの方を解凍するといくつかのファイルが生成されるのですが、似たような名前のファイルが2つあって非常にややこしいのです、、、

uImage-lsp.5.x.buffalo ←こちらをuImage.buffaloに名前を変更してTFTPDの転送に使用しました。

uImage-88f5182.buffalo ←サイトによってはこちらを使用するように書かれていますが、筆者の環境ではダメでした。どういう時に、どちらを使うのか?Linkstationの機種によるのか?ファームウェアのバージョンによるのか?イマイチ分からない・・・。両方試してみるしかないのかも・・・。

ポイント 2: TFTPDはバージョン1.01を使用

これもなぜか分からないのですが、最新版の1.12を使うとうまくいかず、古いバージョンを使用したところ、あっさり転送に成功しました。相性問題があるのかもしれません。ちなみにPCはWindowsXP Home SP3です。

ポイント 3: Windowsファイアーウォールとアンチウィルスソフトを無効に

TFTPDの通信を邪魔しそうなものは排除しておきます。なお筆者は余っているWifiルータを使用してLANを作り(192.168.11.200、DHCP有効)、そこにTFTPD用のPC(192.168.11.1)と、Linkstationを接続して作業をしました。無線LAN接続でもできたのかもしれませんが、安定重視ということでPCは有線接続としました。


<以下は実際の作業の進行状況のメモになります>

赤ランプ6回点滅の状態で、本体後ろのファンクションボタンを何回か押すと、青ランプの点滅に切り替わる。この瞬間、TFTPDによるファイル転送開始。2つのファイル(initrd.buffaloとuImage.buffalo)の転送にかかる時間は合計10秒程度。TFTPDのアイコンが青色に変わり、ステータスがバルーン表示される。

その後2分程度待つと、Linkstationの青ランプの点滅が、点灯に変わる。この状態でEMモードで起動しているはず。念のためBUFFALO NAS Navigator2で確認するとよい。

ここで、LSUpdaterを実行する。HDDのフォーマットを行うか聞いてくるので「はい」を選ぶ。1TBのHDDではフォーマットに2分程度。その後ファームウェアの転送に3分程度。これらの作業中、オレンジ色のインフォメーションランプ、赤色のエラーランプが時々点滅する。

この時、LSUpdaterの表示は「Linkstationを再起動しました。しばらくお待ちください。。。」から「Linkstationの起動完了を待っています。しばらくお待ちください。。。」となっている。

ところがこの約2分後、再び赤ランプ6回点滅の状態に。BUFFALO NAS Navigator2からも、先ほどまでEMモードで起動していたLinkstationが見えなくなってしまった。

仕方なく、本体後ろのファンクションボタンを何回か押して、最初に行ったTFTPDによるファーム転送を再度実行。すると今度は、青ランプの点灯に加えて、オレンジ色のインフォメーションランプが点滅する(長2回、短5回なのでファームウェアアップデート中の意味)。

このまま3分程度放置すると、今度はオレンジ色のランプが消え、青ランプが点滅を始める。そのまま5分程度放置すると青ランプ点灯となる。この時、LSUpdaterの表示は「Linkstationのアップデートが完了しました」となり完了。BUFFALO NAS Navigator2からも確認でき、ブラウザからもアクセス可能となった(デフォルトのadmin、passwordでログイン可能)。

一旦電源OFFし、2本目のHDDを増設して電源ON。認識に3~4分程度かかる。青ランプが点灯となり立ち上がったら、ブラウザからアクセスし、HDDの構成(フォーマット、RAIDアレイの構成、等々)を行えば良い。

最後に。2回ファーム転送をするというのはちょっとややこしいが、まぁ直ったからよしとする。もうちょっと気長に待ってLSUpdaterに任せておけば自動で処理されたのかもしれない。あらゆる過程で結構時間がかかるので(といっても、それぞれ2~5分程度だが)途中で焦って電源OFFせず、気長に待つように!

コメント(2)

もりもりさん、はじめまして。
ポイント1でuImage.buffaloはどちらを使えばいいのかわからないとのことですが、LS-SLシリーズの場合はuImage-88f5182.buffaloで、それ以外の機種はuImage-lsp.5.x.buffaloを使います。
また、FW転送後の再起動で2回目のTFTPブートが煩わしいのであれば、FW内のuImage.imgからuImage-lsp.5.x.buffalo(LS-SLシリーズの場合はuImage-88f5182.buffalo)以外を削除してuImage.buffaloにリネームすれば2回目のTFTPブートは必要なくなります。
このuImage.imgの改変に、私はWinRARを使用しましたがパスワードの入力は必要ありませんでした。

コメントありがとうございます。

uImage.buffaloは機種によってどちらのファイルを使うか区別できるわけですね。そして2回目のTFTPブートは回避する方法があるのですね。

次回作業をする際には参考にさせて頂きます。まぁ自分としては、こんな作業は頻繁にはやりたくないですけどね(苦笑)。

コメントする

月別 アーカイブ

OpenID対応しています OpenIDについて
Powered by Movable Type 6.3.7

この記事について

このページは、もりもりが2013年7月14日 23:23に書いた記事です。

ひとつ前の記事は「【809】「たんけんぼくのまち」撮影地巡り(諏訪市豊田編)」です。

次の記事は「【811】第55回思い出のメロディー」です。

最近のコンテンツはインデックスページで見られます。過去に書かれたものはアーカイブのページで見られます。